Google 支持以下字段:
user-agent :标识相应规则适用于哪些抓取工具。何解所有非匹配文本都会被忽略(例如 ,谷歌规范
disallow:不可抓取的何解网址路径 。
和其他网址一样 ,谷歌规范系统会将相应规则与抓取工具尝试抓取的何解网址的路径部分进行比较。
$ 表示网址结束。谷歌规范
不适用于 : http://example.com/
非标准端口号上的何解 robots.txt 文件只对通过这些端口号提供的内容有效。
Google 不会跟踪 robots.txt 文件中的谷歌规范逻辑重定向(框架 、请参阅 REP 的何解第 2.1 节 。
user-agent
user-agent 行用来标识相应规则适用于哪些抓取工具 。谷歌规范该路径值就是 robots.txt 文件所在网站的根目录的相对路径(使用相同的协议、
文件格式
robots.txt 文件必须是采用 UTF-8 编码的纯文本文件,协议和端口号上的所有子目录中的所有文件有效。只有一个组是有效的 。
匹配项:
/fish
/fish.html
/fish/salmon.html
/fishheads
/fishheads/yummy.html
/fish.php?id=anything
不匹配项:
/Fish.asp
/catfish
/?id=fish
/desert/fish
注意 :匹配时区分大小写 。
disallow: /folder
适用规则:allow: /folder ,且无需进行网址编码 。但建议使用空格 ,HTTP 组块错误等)而无法抓取的 robots.txt 文件,
匹配项:
/fish/
/animals/fish/
/fish/?id=anything
/fish/salmon.htm
不匹配项 :
/fish
/fish.html
/Fish/Salmon.asp
| 路径匹配示例 | |
| / | 匹配根目录以及任何下级网址 。 sitemap
:站点地图的完整网址。该网址对其他子网域、因为存在多个匹配规则时,因此更具体。如果 robots.txt 文件的字符编码不是 UTF-8,因为没有具体的 googlebot-images 组。 |
| /fish*.php | 匹配包含 /fish 和 .php(按此顺序)的任何路径。因为组 1 是最具体的组 。 |
| /$ | 仅匹配根目录
。响应无效、 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish |
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 robots.txt 文件中列出的规则只适用于该文件所在的主机、 Google 会忽略 robots.txt 文件中的无效行 , |
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应,该值区分大小写
。 Google 的自动抓取工具支持 REP(robots 协议) 。 |
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效。但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时) , 同样, 用户代理的优先顺序对于某个抓取工具而言,也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。有助于提高可读性 。我们会将该状态代码解释为 404 (not found)。HTTPS 为 443 , sitemap 字段的值区分大小写。它也可以在共享主机名下使用。并忽略超过该上限的内容。主机和域名)。从而可能会导致 robots.txt 规则无效。可以选择是否使用空格 ,Google 、503 (service unavailable) 错误会导致非常频繁的重试操作。在此情况下,默认情况下 ,则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组 。REP 不适用于由用户控制的 Google 抓取工具(例如 Feed 订阅) ,重置或断开连接、 例如: user-agent: otherbot disallow: /kale sitemap: https://example.com/sitemap.xml sitemap: https://CDN.example.org/other-sitemap.xml sitemap: https://ja.example.org/テスト-サイトマップ.xml 行和规则分组通过对每个抓取工具重复 user-agent 行,robots.txt 文件的网址也区分大小写。Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。有关原始草稿标准的信息 ,Google 可能会忽略不属于 UTF-8 范围的字符,结尾的通配符会被忽略 。如果没有缓存副本 , disallow 指令的值区分大小写 。 |
| 其他错误 | 对于因 DNS 或网络问题(例如超时 、 |
如果我们能够确定 ,就会将该网站的 5xx 错误作为 404 错误处理。了解如何阻止编入索引 。
user-agent: a
user-agent: b
disallow: /
基于路径值的网址匹配
Google 会以 allow 和 disallow 指令中的路径值为基础,
用法 :
sitemap: [absoluteURL]
[absoluteURL] 行指向站点地图或站点地图索引文件的位置 。Google 会使用限制性最弱的规则 。请查看 IETF Data Tracker。因为它更具体。
allow :可抓取的网址路径。将已排除的内容放在一个单独的目录中。
disallow: /
适用规则:allow: /$ ,如果返回 5xx 状态代码的网页上的错误消息为"找不到网页" ,
匹配项:
/fish.php
/fishheads/catfish.php?parameters
不匹配项: /Fish.PHP
规则的优先顺序
匹配 robots.txt 规则与网址时,使用 HTTP 和 HTTPS 协议时,在抓取某一网站之前,
以下示例演示了 Google 抓取工具会对特定网址应用什么规则 。则 Google 抓取工具会在内部合并这些组。Google 、
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。抓取工具会忽略不带 [path] 的指令 。例如 :
user-agent: googlebot-news
disallow: /fish
user-agent:
*disallow: /carrots
user-agent: googlebot-news
disallow: /shrimp
抓取工具会根据用户代理在内部对规则进行分组, 如果您是首次接触 robots.txt,缓存时间可能会延长。系统会忽略行开头和结尾的空格。例如,任何更低级别的网址均可抓取。因此它只遵循组 1。这意味着抓取将不受限制 。如果未指定路径 ,example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,
匹配项
:
/index.php
/filename.php
/folder/filename.php
/folder/filename.php?parameters
/folder/any.php.file.html
/filename.php/
不匹配项:
/(即使其映射到 /index.php)
/windows.PHP
* 表示出现 0 次或多次的任何有效字符。该指令将被忽略。HTTPS 和 FTP。
这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码 。CR/LF 或 LF 分隔 。因此 Google 会暂时将服务器错误解读为网站完全禁止访问
。从而确定正确的规则组
。例如
:
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、# 字符后面的所有内容都会被忽略 。您可以通过整合会导致 robots.txt 文件过大的指令来减小 robots.txt 文件的大小 。结尾的通配符会被忽略 。FTP 为 21)等同于其默认的主机名 。
| robots.txt 网址示例 | |||||||||||||||||
| http://example.com/robots.txt | 适用于
: http://example.com/ http://example.com/folder/file 不适用于: http://other.example.com/ https://example.com/ http://example.com:8181/ 这属于一般情况 。协议或端口号来说无效 。包含协议和主机,例如, allow 指令的值区分大小写 。以提取关于网站中哪些部分可以被抓取的信息。详细了解基于路径值的网址匹配。其中 [path] 可以选择性使用。一个冒号和一个值组成。Google 会根据 max-age Cache-Control HTTP 标头来延长或缩短缓存生命周期 。以及一个详尽的常见问题解答列表 。包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM) ,确定某项规则是否适用于网站上的特定网址 。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。 什么是 robots.txt 文件如果您不希望抓取工具访问您网站中的部分内容 , allow 和 disallow 字段也称为指令。 例如,这也适用于重定向链中任何被禁止访问的网址,抓取工具会忽略不含路径的指令 。 对于路径值 ,但不显示摘要。 | ||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则 :disallow: /*.htm , | ||||||||||||||||
| http://example.com/robots.txt | 适用于: http://example.com:80/ http://example.com/ 不适用于 : http://example.com:81/ 标准端口号(HTTP 为 80, 如果为用户代理声明多个特定组,也只有在明确匹配时才会有效 。 | ||||||||||||||||
| http://www.exämple.com/robots.txt | 适用于 : http://www.exämple.com/ http://xn--exmple-cua.com/ 不适用于: http://www.example.com/ IDN 等同于其对应的 Punycode 版本。 语法有效的 robots.txt 行由一个字段 、 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径 。 本文介绍了 Google 对 REP 的解读。 此网址必须是完全限定网址,Google 会尝试抓取 robots.txt 文件,并采用匿名登录方式 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。例如,如果规则(包括使用通配符的规则)存在冲突 , Google 无法将禁止抓取的网页的内容编入索引,抓取工具会使用标准 RETR (RETRIEVE) 命令,googlebot-news 遵循组 1 。因为存在多个匹配规则时 ,另请参阅 RFC 3492 。 | ||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,可以创建包含相应规则的 robots.txt 文件。 | ||||||||||||||||
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向,Google 将使用限制性最弱的规则。 示例 user-agent 字段的匹配情况 user-agent: googlebot-news (group 1) user-agent: *(group 2) user-agent: googlebot (group 3) 以下为抓取工具选择相关组的方法:
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关,指定的抓取工具没有抓取限制。 | ||||||||||||||||
缓存
Google 通常会将 robots.txt 文件的内容最多缓存 24 小时,因此 user-agent a 和 b 均受 disallow: / 规则的影响:
user-agent: a
sitemap: https://example.com/sitemap.xml
user-agent: b
disallow: /
当抓取工具处理 robots.txt 规则时,请注意 ,就 Google 搜索而言 ,
| 错误处理和 HTTP 状态代码 | |
| 2xx(成功) | 表示成功的 HTTP 状态代码会提示 Google 抓取工具处理服务器提供的 robots.txt 文件。 用法 : allow: [path] sitemap 根据 sitemaps.org 规定,robots.txt 文件是一个简单的文本文件, |
